哈佛财经老教授如厕时突发奇想:金叉共振幅图指标:MACD与KDJ完美地结合在一起(附源代码)

家电头条网 2019-06-02

读一本好书



上次阁主给股友们分享一个短线MACD指标,有股友私信阁主,咨询有没有把MACD与KDJ结合在一个幅图中使用的指标,今天就把MACD与KDJ指标完美地结合在一起的金叉共振指标公式分享给大家,阁主先为大家展示这两大指标双剑合璧后的使用效果,之后为需要金叉共振指标的股友附上源代码。



两大指标结合K线图使用,是不是有一种裸K线就可以玩转股市的感觉,这种软件自带的指标,更适合喜欢追求大道至简的股友,简简单单的K线图,完美地结合MACD指标与KDJ指标,看图效果一目了然。下面阁主为需要本指标的股友附上源代码。主力高控盘战法,精准捕捉涨停大牛股,成功率高达86%,想学习如何把握牛股的想学习如何去把握买卖点的可关注维\\姓号:kq60019,获取更多的股票投资要诀,不断地优化自身的投资体系。

DIF:(EMA(CLOSE,12)-EMA(CLOSE,26))*100;

DEA:EMA(DIF,9);

MACD:(DIF-DEA)*2,COLORSTICK;

DRAWICON(CROSS(DIF,DEA),DEA,1);

DRAWICON(CROSS(DEA,DIF),DEA,2);

IF(DIF<DEA,DIF,DRAWNULL),COLORGREEN;

DD:=C=HHV(C,180);

EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;

CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;

顶背离:=(DD AND EE AND DEA< HHV(DEA,180))*DEA;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

{顶背:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);}

DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORRED,LINETHICK2;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:SMA(RSV,9,3),COLORYELLOW;

D:SMA(K,9,3),COLORWHITE;

J:3*K-2*D,COLORMAGENTA;

IF(J<D,J,DRAWNULL),COLORFFEE44;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

B1:=REF(C,A1+1)>C AND REF(DIF,A1+1)<DIF AND CROSS(DIF,DEA);

A22:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));

B2:=REF(C,A22+1)>C AND REF("KDJ.K"(9,3,3),A22+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));

B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));

DRAWTEXT(B1,DEA-0.20,'▲MACD底背'),COLORWHITE;

DRAWTEXT(B2,D-0.20,'●KDJ底背'),COLORFF00FF;

{DJ:=CROSS(J,D) AND D<20;

DRAWTEXT(DJ,J-0.3,'低金叉'),COLORCYAN;

MDJ:=CROSS(DIF,DEA) AND DEA<0;

DRAWTEXT(MDJ,DEA-0.3,'低金叉'),COLORGREEN;

DRAWTEXT(CROSS(DEA,DIF),DIF+0.3,'死叉'),COLORYELLOW;

DRAWTEXT(CROSS(D,J),J+0.3,'死叉'),COLORRED;}

A:=CROSS(DIF,DEA) AND CROSS(K,D) AND CROSS(J,D);

DRAWICON(A,LOW*0.98,1);

B4:CROSS(DIF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

DRAWTEXT(B4,L-0.20,'★金叉共振'),COLOR0099FF;

DRAWICON(CROSS(K,D),D,1);

DRAWICON(CROSS(D,K),D,2);

BA:=DEA>REF(DEA,1);

BB:=SUM(BA,5)>=4;

BC:=C<O;

BD:=SUM(BC,5)>=2;

BXG:FILTER(BB AND BD AND J>REF(J,1) AND REF(J,1)<REF(J,2),3);

STICKLINE(BXG,HHV(J,60),HHV(J,60)-20,1,0),COLORRED;

SS:=EMA(C,11);

LL:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,5))/4;

{短:EMA(LL,2),COLORGREEN,LINETHICK2;}

{长:EMA(SS,2),COLORMAGENTA,LINETHICK2;}

AA:=(C-LLV(C,10))/(HHV(C,10)-LLV(C,10));

(CROSS(AA,0.05)-1);

简化公式编写流程图

一位炒股天才的做T绝技:“底部棒槌线,黄金做T段”

棒槌线形态做T技巧

棒槌线有阳线棒槌线和阴线棒槌线两种情况,阳线棒槌线的收盘价格相对于开盘价格上涨。如果阳线棒槌线出现在短线低位,那么可以成为价格上涨的支撑形态。看似多空实力难以判断,但是棒槌线的阳线实体已经能够说明问题,表明多方可以控制价格趋势,股价更容易出现上涨走势。

在阴线棒槌线中,收盘价格相对于开盘价格下跌,并且有明显的阴线实体出现,提示我们交易机会正在减少,价格很容易出现回落的走势。

不过作为超短线T+0交易,即便股价出现下跌,我们双向交易依然可以盈利。在股价完成棒槌线形态的过程中,价格双向波动的空间较大。我们在价格异动的时候把握好买卖点位,自然有利可图。

棒槌线形态特征

股价双向波动强度较大,因此我们会发现股价在完成棒槌线的过程中有非常明显的高强度运行痕迹。从形态上看,棒槌线存在较长的上影线和下影线,并且棒槌线的K线实体相比十字星形态更长,股价波动空间会更大。

形态特征

A.存在上影线和下影线:由于股价波动空间较大,分时图中股价双向波动以后在K线图上完成了较长的影线形态,这是我们关注的地方。影线较长,价格波动空间较大,我们高抛和低吸的价位更加有利,获利空间也会更大。

B.K线实体较长:虽然棒槌线有较长的影线,但这并不影响K线实体长度。棒槌线有明确的K线实体,而实体表现出来的阴线特征说明价格趋向下跌。类似的,棒槌线的阳线特征提示价格正在回升。

C.价格波动空间较大:通常十字星是双向波动空间较大的K线形态,而棒槌线的实体较长,存在明显的影线,所以价格波动空间显然会较大。正因为如此,我们在棒槌线形态出现的时候才有机会获得较好的投资效果。在价格运行期间,能够获得足够低的买点和足够高的卖点,这是T+0交易所必需的条件。具体案例如图4-7所示。

图4-7 甘肃电投日K线图

操作要领

1.从价格趋势来看:我们确认股价明显脱离了缩量调整状态,价格运行在高位的时候,该股活跃度较高。在价格双向波动过程中,我们更容易完成超短线T+0交易过程。

2.从量能表现来看:我们确认F位置的量能已经达到100日等量线上方,这是非常难得的放量信号。同时,我们发现放量趋势异常明显,价格表现因此会更加活跃。在成交量明显高位运行的情况下,股价活跃度不会减小。

3.从阳线特征来看:我们发现该股很容易出现实体较长的大阳线形态。即便在股价波动强度较大的时候,图中棒槌线也依然容易形成阳线棒槌线。而价格上行的总体趋势还未结束,因此我们有机会在棒槌线形态出现的时候更好地进行T+0交易。

总结:我们确认价格处于回升趋势中,股价走势较强,这个阶段的交易机会很多。特别是在价格高位出现棒槌线形态以后,我们可以利用股价双向波动的机会高抛低吸,提升盈利的空间。